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Preface 

Statement 

You are welcome to use the product of Xi’an NovaStar Tech Co., Ltd. (hereinafter referred to as 
NovaStar). This document is intended to help you understand and use the product. For accuracy 
and reliability, NovaStar may make improvements and/or changes to this document at any time and 
without notice. If you experience any problems in use or have any suggestions, please get in touch 
with us via the contact information given in the document. We will do our best to solve any issues, as 

well as evaluate and implement any suggestions. 

This product has a built-in media playback and control software that is for your use only. The 
ownership of the software belongs to our company. You can make copies, but only for personal 
use. If you want to use this software for other purposes, especially for commercial purposes, 
please contact our company. Our company reserves the right to pursue legal liability for any 
infringements.  

This product is an electrical device, please pay attention to the electricity safety. Please read this 
manual carefully before use. Improper operation may cause damage to the product. Our company 
assumes no responsibility for any property damage and personal injury caused by improper 
operations that are not followed in accordance with the instructions in this manual. If this article 
conflicts with the local laws and regulations, the local laws and regulations shall prevail.  

Symbols 

Symbol Description 

 Danger 
Indicates a hazard with a high level of risk, which if not avoided, will result in death or 
serious injury. 

 Warning 
Indicates a hazard with a medium or low level of risk, which if not avoided, could result in 
minor or moderate injury. 

 Caution 
Indicates a potentially hazardous situation, which if not avoided, could result in equipment 
damage, data loss, performance degradation, or unexpected results. 

  Note 
Provides additional information to emphasize or supplement important points of the main 
text. 
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Change History 

Release Version Release Date Description 

V1.8.0 2022-09-28  Updated the device rear panel. 

V1.7.0 2022-08-02 

 Added the descriptions for graphics cards HPGA4000 and 
HPGA5000. 

 Deleted the descriptions for the graphics card HPG5000. 

 Updated the control software name. 

 Updated the accessories. 

V1.6.0 2022-04-15 

 Added the stage and layer locking functions. 

 Added the sound channel settings and sound channel 
mapping function. 

V1.5.0 2022-01-17  Changed the TCP/IP default port number. 

V1.4.0 2021-11-30 

The built-in software Kompass FX3 supports the following 
new functions:  

 The function of poroject packging 

 The position adjustment of playback collection 

 The quantity change of max. output partitions 

V1.3.0 2021-11-04 

 Updated the maximum loading capacities of the graphics 
cards. 

 Updated the recommended video coding format 
descriptions. 

V1.2.0 2021-09-20 

 Updated the device rear panel. 

 Added the rules for the mosaic of connectors on the 
graphics card. 

V1.1.0 2021-08-30 

 Added the descriptions of the HPG4000 graphics card. 

 Added the following supported input sources. 

− NDI sources 

− Sources from capture devices 

− Website sources 

− Stream media sources 

− Media collections 

V1.0.4 2021-06-16 Updated the power consumption. 

V1.0.3 2021-05-28 Updated the media file format descriptions. 

V1.0.2 2021-05-14 Updated the product accessories. 

V1.0.1 2021-05-12 

 Updated the appearance and descriptions of the power 
module on the rear panel. 

 Updated the descriptions of the graphics card. 

V1.0.0 2021-04-22 First release 
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1   Overview 

Introduction 

The ET4000 is a brand new media server developed by NovaStar, which is specifically designed for 
multimedia exhibition halls, banquet halls, stage performances and other creative fixed installation scenarios. 
The ET4000 provides an excellent pixel-to-pixel display with ultra-high definition, diversified mosaic creativity 
and outstanding media arrangements for professional stage performances. Built-in with intuitive and user-
friendly media playback and control software, the ET4000 enables simplified stage display management and 
best-in-class human-machine interaction. 

Features 

 A single unit supports up to 8K×4K output capacity, ultra-high-resolution video decoding and pixel-to-pixel 
display 

 Free partitioning, reorganizing and rotating of multiple outputs for irregular screen configuration, 
unleashing your creative mosaic ideas 

 A single output can be split into up to 64 partitions, allowing for quick mapping settings and ultra-wide 
screen configuration 

 Playback of up to 8 layers and 1 audio simultaneously 

 Visualized program arrangement and management 

 Live and pre-edit modes 

− The program editing and playback are in sync in live mode 

− Edit the programs first before displaying them on the screen in pre-edit mode 

 Media library management, including videos, pictures, PowerPoint files and audios 

 Media file sorting 

 Media file batch import 

 NDI sources, website sources, sources from capture devices and stream media sources supported 

 Media collection configurations 

 Up to 1080p PowerPoint files supported 

 Using a laser pointer for moving between slides in PowerPoint 

 Playback progress management 

 Shortcut key for program jumping and auto jumping settings 

 Configurable layer size and priority 

 Main KV jumping settings 

 Main media based playback progress management 

 Crossfade on program switching 

 Layer mask, cropping, keying, blurring and opacity adjustment 

 Hardware decoding supported 

 One-click FTB 

 Auto startup of built-in software on system power on, auto program playback on software startup 

 Control software VICP (Visual Intelligent Control Platform), enabling a highly efficient and user-friendly 
control experience 
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Appearance 

Front Panel 

 

No. Area Description 

1 Power button Power on or power off the device. 

2 USB ports 2x USB3.0 

 Connect to a mouse and keyboard. 

 Insert a USB drive for importing media files. 

Rear Panel 

 

 Note 

The rear panel picture shows the basic configuration without any graphics cards installed. Please go to 1.4 

Optional Items to select the desired graphic card which is a must for the system. 

 

No. Area Qty. Description 

1 USB ports 10  4x Type-A USB 2.0 

 2x Type-A USB 3.2 Gen1 

 3x Type-A USB 3.2 Gen2 
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 1x Type-C USB 3.2 Gen2×2 

 Connect to the mouse and keyboard or insert the USB drive. 

2 HDMI 2.0 

DP 1.2 

1 Integrated graphics card output via DP 1.2 or HDMI 2.0  

 Connect to a monitor for displaying the software interface. 

 Max. output resolution: 3840×2160@60Hz 

3 Ethernet port 1 1x RJ45 connector for Ethernet networking 

4 Audio 
connectors 

3  1x MIC IN: 3.5 mm microphone input connector 

 1x Line IN: 3.5 mm external audio input connector  

 1x Line OUT: 3.5 mm audio output connector 

5 Graphics card 
and sync card 

- Graphics card and sync card slots 

Please go to 1.4 Optional Items to select the desired graphics card. 

 Notes 

 At most two graphics cards can be configured. 

 The graphics card does not support irregular mosaic layouts. 
The mosaic layout must be 1×2, 1×3, 1×4, 2×2, 2×1, 3×1 or 
4×1. 

 The output resolutions of the graphics card connectors that are 
used for mosaic must be the same. 

Hardware/Software 

Power supply 750 W (GreatWall) 

CPU 11th Generation Intel® Core™ Processor (I7_11700K) 

Memory 4x 8GB DDR4 high-speed memory 

Mainboard MPG Z590 

Storage  System disk: Samsung M.2 SSD 250GB (Samsung SSD 980) 

 Storage disk: Samsung M.2 SSD 500GB (Samsung SSD 980) 

Fan Quiet fans (PCCOOLER), dedicated to high-frequency processors 

Keyboard & Mouse Keyboard and mouse suit (Logitech) 

OS Windows 10 IoT Enterprise LTSC 

Playback and control 
software 

Kompass FX3 and its dongle 

 

Optional Items 

The following table lists the optional items that you need to purchase from NovaStar separately. 

Graphics Card and Sync 
Card 

Specifications 

Graphics card MPG2200 

 

4x DP 1.2 

 Single connector resolution: Up to 4096×2160@60Hz 

 Four connector mosaic output:  

− The mosaic width or height can be up to 16384 pixels. 
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Graphics Card and Sync 
Card 

Specifications 

− The loading capacity can be up to 8192×4320@60Hz. 

 Single connector width: 480–8192 pixels 

 Single connector height: 300–8192 pixels 

 Playback of 1 layer of 8K×4K@30fps SDR video (hardware-decoding) 

 Memory: 5 GB 

 Type: GDDR 5X 

 Bit width: 160 bit 

 Note 

The MPG2200 graphics card cannot work with the sync card. 

Graphics card HPG4000 

 

3x DP 1.2, 1x Type-C 

 Single connector resolution: Up to 4096×2160@60Hz 

 Four connector mosaic output:  

− The mosaic width or height can be up to 16384 pixels. 

− The loading capacity can be up to 8192×4320@60Hz. 

 Single connector width: 480–8192 pixels 

 Single connector height: 300–8192 pixels 

 Playback of 1 layer of 8K×4K@60fps SDR video (hardware-decoding) 

 Memory: 8 GB 

 Type: GDDR 6 

 Bit width: 256 bit 

 Note 

A Type-C to HDMI converter cable is included in the packing list when 
this card is selected. 

Graphics card HPGA4000 

 

4x DP 1.2 

 Single connector resolution: Up to 4096×2160@60Hz 

 Four connector mosaic output:  

− The mosaic width or height can be up to 16384 pixels. 

− The loading capacity can be up to 8192×4320@60Hz. 

 Single connector width: 480–8192 pixels 

 Single connector height: 300–8192 pixels 

 Playback of 1 layer of 8K×4K@60fps SDR video (hardware-decoding) 

 Memory: 16 GB 

 Type: GDDR 6 

 Bit width: 256 bit 
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Graphics Card and Sync 
Card 

Specifications 

Graphics card HPGA5000 

 

4x DP 1.2 

 Single connector resolution: Up to 4096×2160@60Hz 

 Four connector mosaic output:  

− The mosaic width or height can be up to 16384 pixels. 

− The loading capacity can be up to 8192×4320@60Hz. 

 Single connector width: 480–8192 pixels 

 Single connector height: 300–8192 pixels 

 Playback of 1 layer of 8K×4K@60fps or 4K×2K@60fps SDR video 

(hardware-decoding) 

 Memory: 24 GB 

 Type: GDDR 6 

 Bit width: 384 bit 

Sync card 

 

The sync card must work with the HPG4000, HPGA4000, HPGA5000 and 
other high-end graphics cards. 

 2x RJ45  

Accept a frame lock signal and output the signal. 

 1x BNC  

Accept an external sync signal. 

 LED lights 

Indicate the statuses of the sync signal connections. 

Control software Visual Intelligent Control Platform (VICP) 

 

 

  

Xi'an NovaStar T
ech Co., L

td.



 ET4000 Media Server User Manual  
 

 

www.novastar.tech   6  
 

2   Applications 
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3   ET4000 Settings 

Set Main Display 

 Right click on your desktop and select Display settings. 

Figure 3-1 Display settings 

 

 Select a display to set it as the main display. 

Figure 3-2 Multiple displays-1 

 

 Note 

When multiple displays are connected, you can click Identify to show the number at the bottom left corner on 

each display. 
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 For the Multiple displays item, select Extend these displays. 

Figure 3-3 Multiple displays-2 

 

 On the window that appears, select Keep changes. 

Figure 3-4 Confirmation 

 

 Check the box next to Make this my main display. 

Change Resolutions 

3.2.1   Set Standard Resolutions 

 Right click on your desktop and select Display settings. 
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Figure 3-5 Display settings 

 

 Select a display to set it as the main display. 

Figure 3-6 Multiple displays-1 

 

 Note 

When multiple displays are connected, you can click Identify to show the number at the bottom left corner on 

each display. 

Xi'an NovaStar T
ech Co., L

td.



 ET4000 Media Server User Manual  
 

 

www.novastar.tech   10  
 

 For the Display resolution item, select the desired output resolution. 

Figure 3-7 Multiple displays-2 

 

 On the window that appears, select Keep changes. 

Figure 3-8 Confirmation 

 

 Repeat Step 2 to Step 4 to complete the resolution settings for other displays. 

3.2.2   Set Custom Resolutions 

 Right click on your desktop and select NVIDIA Control Panel. 
Xi'an NovaStar T
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Figure 3-9 NVIDIA control panel 

 

 On the NVIDIA Control Panel interface, go to Display > Change resolution. 

Figure 3-10 Change resolutions 

 

 Select the desired display. 

 Click Customize to show the customize window. 
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Figure 3-11 Custom resolution-1 

 

 Click Create Custom Resolution. 

 Read the disclaimer information carefully and click Accept to show the Create Custom Resolution window. 

 Select the desired display. 
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Figure 3-12 Custom resolution-2 

 

 Set the horizontal pixels, vertical lines, refresh rate and scan type. 

 Click Test and then click Yes on the window that appears. 

Figure 3-13 Confirmation 
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Figure 3-14 Custom resolution-3 

 

 Click OK to complete the custom resolution settings. 

After a custom resolution is created successfully, it will appear in the custom area as shown in the figure 
below. 

Figure 3-15 Custom resolution-4 
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EDID Management 

After the display resolution settings, you need to manage the EDID for precise identification of display 
properties and to avoid the on-site screen display disorder. 

Load EDID  

The procedure of how to load the EDID is as follows. 

 Right click on your desktop and select NVIDIA Control Panel. 

Figure 3-16 NVIDIA control panel 

 

 On the NVIDIA Control Panel interface, go to Workstation > View system topology. 

Figure 3-17 NVIDIA control panel 
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 Click EDID (Monitor) next to a desired output connector of the current graphics card to show the EDID 

management window. 

Figure 3-18 EDID (Monitor) 

 

Figure 3-19 Manage EDID  

 

 Click Export EDID and then name the exported EDID file in the window that appears. 
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 Select the Load tab to show the EDID loading window. 

 Click Browse and then select the EDID file exported in Step 4. 

 In the Select Connector to force EDID area, select the desired connector. 

Figure 3-20 Load EDID 

 

 Click Load EDID. 

 On the dialog box that appears, click OK to complete loading the EDID. 

Figure 3-21 EDID loaded successfully 

 

 Go back to Workstation > View system topology to check the EDID status. If the original EDID (Monitor) 

changes to EDID (File), the EDID is loaded successfully.  
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Figure 3-22 EDID loaded successfully 

 

Unload EDID  

The procedure of how to unload the EDID is as follows. 

 On the NVIDIA Control Panel interface, go to Workstation > View system topology. 

 Click EDID (File) to show the EDID management window. 
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Figure 3-23 EDID (File) 

 

 Select the Unload tab and then select the desired connectors. 

Figure 3-24 Unload EDID 

 

Xi'an NovaStar T
ech Co., L

td.



 ET4000 Media Server User Manual  
 

 

www.novastar.tech   20  
 

 Click Unload EDID. 

 After the EDID is unloaded successfully, click OK on the dialog box that appears. 

Figure 3-25 EDID unloaded successfully 

 

 Go back to Workstation > View system topology to check the EDID status. If the EDID (File) changes to 

EDID (Monitor), the EDID is unloaded successfully.  

Output Mosaic 

The graphics card supports connector mosaic output. The output connector mosaic must observe the 
following rules. 

 The graphics card does not support irregular mosaic layouts. The mosaic layout must be 1×2, 1×3, 1×4, 
2×2, 2×1, 3×1 or 4×1. 

 The output resolutions of the graphics card connectors that are used for mosaic must be the same. 

 Right click on your desktop and select NVIDIA Control Panel. 

Figure 3-26 NVIDIA control panel 

 

 On the NVIDIA Control Panel interface, go to Workstation > Set up Mosaic. Xi'an NovaStar T
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Figure 3-27 Set up mosaic 

 

 Click Create new configuration to show the mosaic settings window. 

Figure 3-28 Mosaic settings 
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 Select the screen number from the drop-down list of Number of displays. 

 Select the screen mosaic layout from the drop-down list of Topology (rows x columns). 

 Select the screen orientation from the drop-down list of Orientation of displays. 

 Click Next to proceed. 

Figure 3-29 Select displays 

 

 Select the connected displays and then select their refresh rate and resolution. 

 Click Next to proceed. 
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Figure 3-30 Arrange displays 

 

 Arrange the displays according to the screen arrangement and structure by dragging the available displays to 

the corresponding topology areas. 
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Figure 3-31 Arrange displays 

 

 Click Apply and then click Yes on the confirmation window. 

 Click Next to proceed. 
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Figure 3-32 Adjust overlap and bezel correction 

 

You can perform overlapping adjustment or bezel correction to the vertical or horizontal edges of the display 
as needed.  

1. Select whether to use the same settings for all the vertical or horizontal edges of the display in the Select 
how overlap/bezel correction is applied area. 

2. Select the desired edges and then enter the overlap or bezel correction values for the selected edges. 
Click Apply after the settings are done. 

 Click Finish to complete the mosaic settings. 
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Figure 3-33 Mosaic completed 

 

4   Software Operations 

Software Licensing 

After the ET4000 is started, Kompass FX3 supports two authorization modes: temporary authorization and 
permanent authorization.  

 When Kompass FX3 is temporarily authorized, the remaining days of temporary authorization is displayed 
at the top right.  

 When Kompass FX3 is permanently authorized, no authorization message is displayed at the top right.  

 When Kompass FX3 is not authorized, Trial is displayed at the top right. 

If you want to obtain authorization, please contact our sales engineer for purchasing the dongle or registration 
code. 

In trial mode, the Kompass FX3 text is displayed on the output. 

Dongle detection rules are as follows: 

 When the inserted dongle is recognized, Trial will disappear automatically and the output will not display 
the Kompass FX3 text. 

 Within 3 seconds after the dongle is removed, the software knows the dongle has been removed and 
prompts you that no dongles have been detected, and the software will again display the Kompass FX3 

text on the output in 5 seconds. 
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Figure 4-1 Dongle removed 

 

 When the dongle is inserted and recognized normally, the above window and the Kompass FX3 text on 

the output will disappear automatically. 

User Interface Introduction 

After the software is started, the main user interface is shown in Figure 4-2. The functions of each area are 
described in Table 4-1. 

Figure 4-2 Kompass FX3 user interface 

 

 User interface descriptions 

Area Item Description 

Menu bar Project Project file operations include: 

 New: Create a new project. 

 Open: Open a saved project. 

 Save: Save the current project. 

 Save As: Save the current project as a new project. 

 Package Project: Package the current project file and all media in it 
for easy use in the future. 
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Area Item Description 

Link  Link Settings: Set the primary/backup devices and master/slave 
devices. 

 Update to Backup: Manually update the data on the primary device 
to the backup device.  

 Update to Slave: Manually update the data on the master device to 
the salve device. 

 Disconnect: Disconnect the backup/slave device from the 
primary/master device.  

Settings Settings include system, output, audio, display mode and external 
control settings. 

Help  Use the transcoding assistant. 

 View and export the playback logs. 

 Open the user manual. 

 View the software information. 

语言
/Language  

Change the UI language. The options include English and Chinese. 

Media library & 
Output control 

 Media library: Add the desired media files, including videos, pictures, PowerPoint files, 
audios, website pages, streaming media and texts, etc. 

 Output control: Add the commands for controlling the splicers. 

Stage editing 
area 

Stage  Preview the real-time playback content. 

 Edit the position and size of the added media. 

A Output control buttons 

 : Open the output editing window. 

 : Enable the output screen and display the playback content on 
the screen. 

 : Disable the output screen. 

 : Close the test pattern and display the playback content. 

 : Open and display the test pattern. 

 : Disable the FTB function and display the playback content. 

 : Make the output fade to black. 

B Two editing modes are provided. 

 Live: The playback editing process is displayed on the output screen 
in real time. 

 Pre-Edit: The playback editing process will not be displayed on the 

output screen. After you have completed the editing, click  at the 
top right in the stage editing area to send the playback content to the 
output screen and play the content from the beginning. 

C Quickly adjust the layers. 

 X: Set the initial horizontal coordinate of the layer. 

 Y: Set the initial vertical coordinate of the layer. 

 Width: Set the width of the layer. 

 Height: Set the height of the layer. 
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Area Item Description 

 Rotate: Set the angle by which the layer rotates clockwise. 

 : Bring the selected layer forward. 

 : Send the selected layer backward. 

 : Bring the selected layer to front. 

 : Send the selected layer to back. 

 : Make the selected layer fill the output area. 

 : Lock the stage editing area. 

D Adjust the output area display. 

 : Pan the stage editing area. 

 : Zoom in or out the stage editing area. 

 : Make the stage start at the origin and all layers locate within the 
visible range in the stage editing area. 

E Control and view the playback progress. 

 : Count up timer 

 : Count down timer 

 : Start the playback. 

 : Pause the playback. 

 : Stop the playback. 

 : Adjust the volume. 

 Update: View the progress of updating the data to the backup/slave 
device. 

 Timecode: Set the timecode-based program playback list for the 
program control in shows and more applications. LTC and MTC both 
require external timecode reference devices. 

F Set the media properties, including the layer basic info, opacity, color, 
cropping, transition effect and more. 

Program 
management 
area 

n/50 Indicate the quantities of the edited programs and the total programs in 
the current group. 

 N: Indicates the quantity of the edited programs or the programs that 
have media files. 

 50: Indicates the default quantity of the total programs. When a new 
program is added, the value increases accordingly. 

Program n View the program name. 

Layer and 
layer status 

 Layer n with/without audio: Displays the layer name and indicates 
whether the layer comes with audio or not. 

 : Turn off the layer audio. 

 : Play the layer audio. 

 Icons on the layer: 

− : This icon indicates the layer is the main media and the 
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Area Item Description 

timer in the Playback area is based on this layer. 

− : After the playback of the media in the current layer is 
completed, the layer stops the playback and displays the last 
frame of the playback image. 

− : Within the timing period for the main media, the current 
layer media is in loop playback mode. 

− : Within the timing period for the main media, the audio 
media playback will be stopped after it is finished. 

− Lock: The layer is locked. 

Status bar 
 : Increase or decrease the program column width. 

 : Enable the PowerPoint file playback mode. You can use the 
laser pointer buttons or keyboard buttons to move between slides. 

 : Disable the PowerPoint file playback mode.  

 : Disable the C3 control. 

 : The C3 control is enabled. 

 : The scheduled playback is enabled. 

 : The schedules playback is disabled. 

 Display the current CPU and memory usage. 

Link status  Name: The computer name by default 

 Backup/Salve: Show the statuses of the backup and slave devices. 
These items are shown on the primary/master end only.  

− : Not set 

− : Disconnected 

− : Normal communication 

 

5   Project 

Kompass FX3 allows you to add media files, edit the programs and set the program playback sequence and 
media properties. After all these are done, you can save those configuration as an independent project file to 
your local storage for future use. 

Create New Projects 

There are two methods to create a new project. 

 Start Kompass FX3 and the software will create a new project automatically. 

 Go to Project > New to create a new project. 

Edit Outputs 

Kompass FX3 supports output editing, allowing you to partition the output screen and perform output 
connector mosaic, thus realizing a mosaic output of desired connectors and partitions. 

Click  to open the Edit Output window. 
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Figure 5-1 Edit output 

 

5.2.1   Add Outputs 

Add and bind outputs automatically 

After startup, Kompass FX3 will automatically detect the graphics card connectors and then complete the 
adding and binding of those detected connectors. All the connectors are displayed in the output list on the 
left.  

When you need to change the binding relations between the output connectors and screens, click  to 
change the output name, connector binding and resolution. 

Add and bind outputs manually 

When more graphics cards are installed on the control PC or you want to change the connector quantity in 
a saved project file, you can select to add the outputs manually. 

Click  in the output list area to add an output. 

Figure 5-2 Add and edit outputs 

 

 Name: Change the current output name. 

 Connector: Select the desired output connector from the drop-down list or change the connector binding 
relation. 

 Resolution: Set the desired output width and height. 
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5.2.2   Configure Regular Screens 

 Click  to open the Edit Output window. 

 Organize the output connectors on the right via drag and drop operations to suit the loaded screen. 

Figure 5-3 Connector layout 

 

 Click OK to complete the editing. 

Note: 

In the output editing area, click and drag to select multiple outputs to adjust them simultaneously. 

5.2.3   Construct Irregular Screens 

When you want to output an image of an irregular shape, you can partition the output and reorganize the sub-
outputs to suit the loaded screen.  

Output Partitioning 

This function divides an output into several sub-outputs, breaks up and reorganizes the outputs, realizing easy 
reconstructing and management for irregular output images. 

You can realize the output of an irregular image via the reorganizing of regular output connectors. 

Figure 5-4 T-shape output image 
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 Select a partition layout in the output list area. 

Figure 5-5 Output partitioning 

 

 : 1x sub-output 

 : 2x sub-outputs in horizontal position 

 : 3x sub-outputs in horizontal position 

 : 4x sub-outputs in horizontal position 

 : 2x sub-outputs in vertical position 

 : 2x sub-outputs in both horizontal and vertical positions  

 : 3x sub-outputs in vertical position 

 : 4x sub-outputs in vertical position 

 : Custom layout 

 Select a sub-output and set its position and size. 

 Position: 

− X: Set the initial horizontal position of the sub-output area. 

− Y: Set the initial vertical position of the sub-output area. 

 Size:  

− Width: Set the width of the sub-output area. 

− Height: Set the height of the sub-output area.  

Sub-Outputs Reorganizing 

The mosaic output of multiple graphics card connectors is supported.  

After startup, Kompass FX3 will automatically detect the graphics card connectors and display all the 
connectors in the output list on the left. 

 : Enable the output. 
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 : Disable the output. 

 : Delete the output. 

Click  to change the output name, connector binding relation and resolution. 

 Click and drag the sub-outputs on the right to reorganize them. 

Figure 5-6 Sub-outputs reorganizing 

 

You can change the size and position of the sub-output at the bottom. 

Figure 5-7 Output adjusting 

 

 Name: Change the current output name. 

 X: Set the initial horizontal position of the sub-output or output on the stage. The adjusting reference is the 
top left corner of the stage. 

 Y: Set the initial vertical position of the sub-output or output on the stage. The adjusting reference is the top 
left corner of the stage. 

 Width: Set the width of the sub-output or output. 

 Height: Set the height of the sub-output or output. 

 Rotate: Set the rotation angle (clockwise) of the sub-output or output. 

 Click OK to complete the reorganizing. 

After the reorganizing, you can add the layer image to the stage area. The mapping between the sub-output 
and image is shown as follows. 
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Figure 5-8 Sub-output and image mapping 

 

Manage Media 

You can add the desired media files to the current media library. Kompass FX3 supports pictures, videos, 
PowerPoint files, audio media files, NDI, websites, streaming media and sources from data acquisition cards. 

The supported media formats are as follows: 

 Video: mp4, avi, mkv, flv, mov, wmv, mpeg, m4v 

 Picture: jpg, jpeg, bmp, png, gif, ico 

 Audio: mp3, aac, flac, amr, ape, wav, wma 

 Microsoft Office files: PowerPoint (1080p) 

Note: 

Recommended video coding formats: 

• 4K ＜ resolutions ≤ 8K: H.265 (HEVC) or VP9 recommended 

• Resolutions ≤ 4K: H.264 (AVC) recommended 

For a better image quality experience, the following video bitrates are recommended. 

Recommended video bitrates for SDR uploads: 

Type Video Bitrate Standard Frame Rate 

(24 Hz, 25 Hz, 30 Hz) 

Video Bitrate High Frame Rate  

(48 Hz, 50 Hz, 60 Hz)  

4320 (8K) 75 to 90 Mbps 110 to 135 Mbps 

2160p (4K) 35 to 45 Mbps 53 to 68 Mbps 

1440p (2K) 16 Mbps 24 Mbps 

1080p 8 Mbps 12 Mbps 

5.3.1   Add Media Files 

You can select to import a single media file or a folder including multiple media files. 
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5.3.1.1   Add Local Files 

 Click  at the bottom left corner of the Media Library area, or right click the area to select Add Local File. 

 Select the target media files and click Open. Kompass FX3 will import the selected files to the media library 

automatically. 

 Importing a single file: Select the desired file and click Open to complete the importing. 

 Importing multiple files: Press the Shift/Ctrl key, select the desired files, and then click Open to complete 

the importing. 

 Drag and drop to import: Select one or multiple media files and drag them to the blank area of the media 
library to complete importing. 

5.3.1.2   Add Local Folders 

 Click  at the bottom left corner of the Media Library area, or right click the area to select Add Local 

Folder. 

 Select the target folder and click Select Folder. Kompass FX3 will import the folder and the media files in it to 

the media library automatically. 

You can also select one or multiple folders and drag them to the blank area of the media library to complete 

importing folders quickly. 

5.3.1.3   Add Text 

Kompass FX3 supports the text as a kind of media and can play the text media. 

 Right click the Media Library area to show the context menu and then select Add Text. 

Figure 5-9 Add text 

 

 Enter the desired content in the Text area. 
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 Adjust the text font and style. 

You can set the following text attributes. 

 : Make the text bold or not. 

  : Italicize the text or not. 

 : Underline the text or not. 

 : Align the text to the left. 

When the display area width is larger than the text width and the moving is set to Static, align the text to 

the left of the display area. 

 : Center the text horizontally. 

When the display area width is larger than the text width and the moving is set to Static, center the text 

horizontally to the display area. 

 : Align the text to the right. 

When the display area width is larger than the text width and the moving is set to Static, align the text to 

the right of the display area. 

 : Align the text to the top. 

When the display area height is larger than the text height and the moving is set to Static, align the text to 

the top of the display area. 

 : Center the text vertically. 

When the display area height is larger than the text height and the moving is set to Static, center the text 

vertically to the display area. 

 : Align the text to the bottom. 

When the display area height is larger than the text height and the moving is set to Static, align the text to 

the bottom of the display area. 

 Enter a name for you text in the text box next to Name. 

 Set the text font and font size. 

Select the desired font from the drop-down list and the default font is Arial.  

Select the desired font size from the drop-down list and the default size is 48. You can only select a number 

from the drop-down list and you cannot enter a number manually.  

 Set the text font color. 

Gradient and Pure Color are supported. 

 Pure Color: Select Pure Color from the drop-down list and select the desired color block next to Presets. 

When you are not interested in any of the preset colors, click  to open the Select Color window to 
customize your own color, and then click OK to complete the pure color settings. 

 

 Gradient: Select Gradient from the drop-down list and the default gradient color is displayed. 

Click two color blocks at the both ends of the gradient color to customize your own gradient colors. Set the 
gradient angle to complete the gradient color settings. 

 

 Set the text moving effect and speed. 

 The moving effects include Static, From Left, From Right, From Top and From Bottom. 

 Speed: Set the moving speed of the text. This parameter is available when the moving effect is set to 
Static. 
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 Set the text display mode in the display area. 

If Adaptive is selected, the text fills the display area; if Adaptive is deselected, the text is shown in its set 

size. 

Note:  

If the area width or area height is smaller than the text width or height, the text will be cropped. 

 Set the display area color. 

3. Click  to open the Select Color window. 

Figure 5-10 Select display area color 

 

4. The Alpha channel value indicates the color transparency. The value ranges from 0 (totally transparent) to 

255 (opaque). 

5. Click OK to complete the display area color settings. 

 Click OK to complete the whole text settings. 

5.3.1.4   Add Sources from Acquisition Devices 

Kompass FX3 can obtain input sources via the data acquisition card. 

Figure 5-11 Data acquisition card connection 

 

 Right click the blank area of Media Library and select Add Acquisition Equipment. 
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Figure 5-12 Add acquisition equipment 

 

 On the displayed window, enter the capture device name next to Name. 

 Select a data acquisition card name next to Device Name. 

 The system will automatically read the collected resolution and frame rate. 

 Click OK to complete adding the capture device. 

5.3.1.5   Add NDI Input Sources 

Before adding an NDI input source, you must configure the NDI source image size and position in NDI Sender 

and enable NDI so that Kompass FX3 can search and find the NDI source and add it. 

Note: 

The computers running the NDI Sender and Kompass FX3 must be on the same network segment. 

Configurations in NDI Sender 

 Double click the NDI Sender shortcut on the desktop to open the NDI Sender software. 

Figure 5-13 NDI Sender 

 

 Enter an NDI name. 

 Click Reset. 

After the name is changed, you must click Reset to make the setting take effect. 

 If there are multiple screens in NDI Sender, select the screen that you want to send. 

If you want to send multiple screens, select the first screen that you want to send. 

 Click Select ROI, click and drag the mouse to select the display area that you want to send. 

In the Sent ROI area, you can see the position and size of the sent image. You can also change the x, y, w 

and h values to change the image position and size. 

Xi'an NovaStar T
ech Co., L

td.



 ET4000 Media Server User Manual  
 

 

www.novastar.tech   40  
 

 x: The horizontal offset from the sent area to the selected screen’s left edge 

 y: The horizontal offset from the sent area to the selected screen’s top edge 

 w: The horizontal width of the sent area 

 h: The vertical height of the sent area 

 Click OK to complete image settings in NDI Sender. 

 Click Start to complete NDI Sender settings. 

Note: 

After the settings, you can click Show ROI to see the image position and image size you have set. 

Add NDI Sources 

 Right click the blank area of Media Library in Kompass FX3 and select Add NDI Media. 

 The system will automatically search on the current network segment for all the devices with NDI enabled. 

Figure 5-14 Add NDI sources 

 

 Select the NDI sources from the NDI list. 

 Click OK to complete NDI source adding. 

Note: 

After adding NDI sources, you can right click an NDI source and select Edit to change the NDI source name. 

5.3.1.6   Add Website Input Sources 

Prerequisites 

The computer running Kompass FX3 is connected to the network. 
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Operating Procedure 

 Right click the blank area of Media Library and select Add Website. 

Figure 5-15 Add website 

 

 Enter the desired website name next to Resource Name. 

 Enter the tab name in the left text box next to Website URL. 

 Enter the complete website domain name in the right text box next to Website URL. 

 Click Add Tab to add a new tab page. 

 Enter the tab name and domain name of the new tab page. 

 Click OK to enter the added website. 

Figure 5-16 Entered the added website 

 

 Click the drop-down lists on the top right to change the webpage output resolution and mode. 

Select your desired output resolution of the webpage from the first drop-down list next to Webpage Output. 

Select the webpage output mode from the second drop-down list next to Webpage Output. The options 
include Default Mode, Screenshot Mode and Window Mode. 

 Default Mode: This is the default output mode of the webpage.  

 Screenshot Mode: If there are monitoring contents on the webpage, it is recommended you adopt this 
mode; however this mode consumes more system resources. 
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 Window Mode: There is no output image preview in the stage editing area in Kompass FX3. The output 
image is displayed on the corresponding screen and can be controlled using the mouse. 

 Click × at the top right corner of the website to close the website and complete adding the website. 

Notes: 

• When multiple tabs are opened, the tab where you stay on before closing the website will be used as the 

input source. 

• If you opened other website pages and the new page is displayed on the new tab, the system 

automatically adds the new tab page. 

5.3.1.7   Add Streaming Media 

Kompass FX3 supports adding streaming media in rtsp and rtmp formats as input source. 

 Right click the blank area of Media Library and select Add Streaming Media to open the window of adding a 

media network address. 

Figure 5-17 Add streaming media 

 

 Enter the media path in the URL field. 

The path must begin with “rtsp://” or “rtmp://”. 

 Click OK to complete adding the media path 

5.3.1.8   Add Media Collection 

Multiple videos or videos and pictures can be combined with a specific order to form a new video source 

called media collection. The videos and pictures in the collection can be played automatically according to the 

set mode. 

Note: 

The PowerPoint files, NDI sources, websites and media paths cannot be added to the media collection. 

 Right click the blank area of Media Library and select Add Media Collection to open its window. 
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Figure 5-18 Add media collection 

 

 In the All Media area, select the media files you want to add to the media collection 

 Click  in the middle to add the selected files to Collection Media. 

You can click and drag the media to adjust its order in the collection media. 

 Click and drag the media to change its order in the Collection Media area. 

 For picture media, select a picture in Collection Media and click the value in the Duration column to change 

the playback duration of the picture. 

For video media, select a video in Collection Media and click the value in the Loop column to change the 

number of times that the video can be played consecutively. 

Notes: 

• The duration of video media cannot be set. 

• The number of playback times of picture media cannot be set. 

 In the Name filed, enter a name for the media collection.  

 In the Transition filed, select a media switching effect. Supported effects include Fade and Cut. 

 In the Playback field, select a playback order of media files in the media collection. Supported orders include 

Sequential and Shuffle. 

 Click OK to complete adding a media collection. 

5.3.1.9   Add Control Commands 

Kompass FX3 supports the control of the back-end splicers via the control commands. It is recommended the 
trained personnel use this function.  

 Select the Output Control tab. 
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Figure 5-19 Output control 

 

 Click  at the bottom-left corner or right click the blank area and select Add to open the Edit Control 

Command window.  

Figure 5-20 Add control commands 

 

 Enter the control command name next to Name. 

 Enter the splicer information. 

1. Select the connected splicer next to Select Device. 

2. Enter the splicer IP address next to Device IP. 

3. Enter the port number for the external control next to Port Number. 

 Configure the control command. 

4. Select the control command type next to Command Type. 

5. Enter the control command value next to Value. For the control command values, please refer the control 

protocol of the corresponding splicer.  

 Click OK to complete the settings. 

Notes: 

• Each control command is a media file. 

• The playback duration of the command media is fixed to 3s. If a program has the command media only, 

the output will be black for 3s. 
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5.3.2   Manage Media Files 

Renaming 

 Right click the media file or folder and select Rename. Enter a new name in the text box that appears.  

 Click the media file or folder and press the F2 key. Enter a new name in the text box that appears.   

Deleting 

There are three methods to delete a media file. 

 Select the desired media file and click . 

 Right click the media file and select Delete. 

 Click the media file and press the Delete key. 

Management 

You can create folders to classify the added media files. 

 Click  at the bottom left corner in the Media Library area, and then select New Folder and name the 

folder. 

 Right click the Media Library area, and then select New Folder and name the folder. 

 Select the desired media files and drag them to the new folder for better classification and management. 

 Change the order of the files or folders by simply dragging and dropping them. 

Switching View 

Click the icon next to Media Library to switch the view mode. 

 In list view mode, click  to switch to the thumbnail view mode. All media files will be displayed in 
thumbnails and folders will not be displayed. 

 In thumbnail view mode, click  to switch to the list view mode. The media files will be displayed in 
folders. 

Edit Programs 

The playback unit of Kompass FX3 is a program. Each program supports at most eight layers and one audio. 

5.4.1   Edit Layers 

Click and drag a media file to the layer in a program, and then adjust the layer in the stage editing area, such 
as the layer size and position. 

 Select a media file in Media Library and drag it to the desired layer or output area. 
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Figure 5-21 Edit programs 

 

 Adjust the layer size, position, rotation and priority. 

Figure 5-22 Adjust layers 

 

 Position adjustment: Drag and move the layer to adjust the layer position quickly, or fill in the values for the 
following parameters to precisely adjust the layer position. 

− X: Set the distance between the left edge of the layer and the left edge of the stage. 

− Y: Set the distance between the top edge of the layer and the top edge of the stage. 

 Size adjustment: Drag the layer edge to adjust the layer size quickly, or fill in the values for the following 
parameters to precisely adjust the layer size. 

− Width: Set the layer width. 

− Height: Set the layer height. 

 Rotate: Set the angle by which the layer rotates clockwise. 

 Priority adjustment: 

− : Bring the selected layer forward. 

− : Send the selected layer backward. 

− : Bring the selected layer to front. 

− : Send the selected layer to back. 

− : Make the selected layer fill the output area. 

 Set whether to play the layer audio. 

Click the audio icon in the Layer column on the left of the program columns to set whether to play the layer 

audio. 

 : Play the audio that comes with the layer. 

 : Do not play the audio that comes with the layer. 

 Group the media. 
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6. In the stage editing area, select the target media. 

Press the CTRL key and click the mouse to select multiple media. 

7. Right click to open the context menu and select Create Group. 

− For the media in the same group, the same icon appears on the top left of each layer as shown below. 

− For the group media, you can perform the playback, fast forward, rewind, pause and stop operations 
on all the media in the group simultaneously. 

Figure 5-23 Layer group 

 

 Lock the layer media. 

After a layer is edited, you can lock the layer to avoid unexpected changes to the layer caused by 
misoperation. 

8. In the stage editing area, right click the target media to open the context menu. 

Figure 5-24 Lock media 

 

9. Select Lock to lock the selected media. After locked, the layer cannot be moved. 

− After the layer is locked, lock appears at the top right corner of the layer in the Program Management 

area. 

− After locked, the layer cannot be moved or re-sized, but the layer input source can be replaced. 

− Right click the locked layer and select Unlock to unlock the layer. 

Notes: 

• In the stage editing area, you can click and drag to select multiple layers. 

• After you have completed all the editing in the stage editing area, click  to lock the stage to avoid the 
layout changes in the stage caused by misoperation. 

• Select Locate Media Resource to quickly find out where the media file is in the media library. 

• If the selected media is a webpage media that has multiple tab pages, you need to set the desired 
playback tab for each media respectively. 
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5.4.2   Set Program Properties 

Right click a program to open the context menu as shown in the following, and you can set the program 
properties as needed. 

Figure 5-25 Set program properties 

 

 Rename: Give the program a new name for better management. 

 Delete: Delete the current program. All the layers, layer settings and media properties will be deleted. 

 Copy: Copy the layers, layer settings and media properties in the current program. 

 Paste: Paste the copied program to a new program. 

 Insert and Play: Play the currently-selected program. The program being played is paused until the 
playback of the inserted program ends. 

− If the main media is set to None, this function is not supported. 

− If the programs are scheduled, this function is not supported. 

− In link mode, the insert and play status is synchronized to the slave or backup terminal. 

− In pre-edit mode, this function is not supported. 

− During the playback of a media collection, after the playback of the inserted program ends, the paused 
program starts to play from the beginning rather than from the pausing point. 

− When there are continuous inserted programs, after the playback of those programs ends, the program 
before the last insertion rather than the program before the first insertion continues to play. 

− After the insertion, the paused program has a different label color for easy distinction.  

 Add Columns to Left: Insert a specified number of program columns to the left of the currently selected 
program column. 

 Add Columns to Right: Insert a specified number of program columns to the right of the currently selected 
program column. 

Notes: 

• To add program columns to left or right, click  to set the number of columns to be added first and then 
click Add Columns to Left or Add Columns to Right. 

• When you perform the copy and paste operations on a program, the pasted program becomes a newly-

added program. 

 Main KV: Set the current program as the main KV (key video). 

− After a KV program is set, if you add a layer in another no-layer program, the added-layer will 
automatically match the layer style and properties in the KV program. 

For example, after you have set the position, size and rotation of the layer 1 in the KV program, if you 
add a layer in another empty program, the new layer will follow the same layer position, size and 
rotation with the layer 1 in the KV program. 
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− If you set KV program after you add the layers to an empty program, the layers will not follow the layer 
style and properties in the KV program. 

 Main Media: Set which layer is used as the main media. The playback timing and program switching are all 
based on the main media. 

When Main Media is set to None, no program jumping is performed. All media in the program will be 

played completely and with a set ending action after the program playback ends. 

Notes: 

 If Main Media is set to None, the program does not support the insert and play function, but another 

program can be inserted before it.  

 If Main Media is set to None in the pre-edit mode, click Take to make the setting take effect. 

 If Main Media is set to None and then the program is added to the schedule list, the playback of the 

program is not limited by the set loop times and the program jump settings do not take effect. 

 If you have added the program to the schedule list, Main Media cannot be set to None. 

 After Program Ends: Set the actions after the current program playback ends. 

 

− Loop Playback (default): The current program will be played circularly. 

− Jump to Next: The next program will be played automatically after the current program is stopped. 

− Stop Playing: The playback will be stopped after the current program is stopped. 

− Jump to KV: The main KV program will be played automatically after the current program is stopped. 

− Jump to: You can select the desired program and the specified program will be played automatically 
after the current program is stopped. 

− Apply to All: Apply your selected option for After Program Ends to all the programs. 

 Cache Program: Cache the next desired program in advance to improve program switching efficiency. 

Before you set any program to be cached here, please go to Settings > Output Settings to enable the 

function first. 

− None: Do no cache a program in advance. 

− Auto Identify: The system will automatically identify the next program to be played and start to cache it. 

− Program n: Select the desired program to be cached. If the next program and the cached program are 
not the same one, the next program will be played automatically and the cached program will not be 
played. 

 Timecode: Set the timecode-based playback control for the current program, specifying the time to start, 
pause, resume and stop the program playback. 

As shown in the below figure, (00:00:00:00 as the timing base) the program starts the playback at the 10 th 
second, pauses the playback at the 30th second, resumes the playback at the 40th second and stops the 
playback at the 50th second. 

− When the scheduled playback function is enabled, the timecode settings are not available. 

− When the timecode function is enabled and the timecode settings are for a program being played, the 
insert and play function is not available. 
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Figure 5-26 Timecode settings 

 

5.4.3   Play Programs 

After you have completed the program editing, play the programs through either of the following two methods. 

 Click  next to the program name in the Program Management area. 

 Click  next to the program name in the Playback area. 

 Click  or  next to each media to play or pause the playback of the selected media. 

 For the media of the same group, drag the progress bar of a single media to control the synchronous 
playback of all the media in the group. 

Note: 

If there are no PowerPoint files in the playlist and the PowerPoint file playback mode is disabled, you can use 

the arrow keys, Page Up and Page Down keys on the keyboard to switch programs, and press the space key 

to start the playback. 

5.4.4   Set Media Playback Properties 

You can set whether to mute the playing, status when playback stopped and playback duration. 

 Click the playing media in the Program Management area or in the Output area to select the media. 

 In the Media Properties area within the Output area, click Basic to set the basic properties of the media. 

Figure 5-27 Basic properties 

 

 Volume adjustment: Adjust the output volume of the program media. 

 Stop Playing: Set the status or action when the playback of the current media ends. 

− Hold on Last Frame: After the playback of the current media ends, the output displays the last frame of 
the playback media. 

Xi'an NovaStar T
ech Co., L

td.



 ET4000 Media Server User Manual  
 

 

www.novastar.tech   51  
 

− Black Screen: After the playback of the current media ends, the output displays a black screen. 

− Loop Playback: The current media will be played circularly after the playback ends.  

− Stop Playing: The playback will be stopped after the playback ends. When the media file type is audio, 
this option is available. 

Note: 

The streaming media sources, sources from acquisition devices, text and NDI sources do not support the 

setting of the action after the playing stopped. 

 Duration: View or set the playback duration of the media.  

− The default playback duration of pictures and websites is 10 minutes. 

− The default playback duration of texts is 1 hour. 

− The media collections, NDI sources and videos do not support duration settings. 

 Lock Aspect Ratio: Keep the aspect ratio of the media file unchanged during the adjustment. 

 Accurate Frame Seek: Enable this function to precisely seek at and play an exact frame in a video stream. 
Only videos supports this function. 

Notes: 

• When the media file type is a PowerPoint file, the basic property settings are unavailable. 

• When the media file type is audio, Hold on Last Frame and Black Screen options are unavailable. 

• When the accurate frame seek function is enabled for the layer in the main KV program, the setting does 

not apply to the layer in other newly-added programs. 

• When the accurate frame seek function is enabled for a program, after the program copy and paste 

operations, the function is also enabled for the pasted program. 

5.4.5   Set Layer Opacity 

You can set the overlapping effect of the output images by adjusting the layer opacity. 

 Click the playing media in the Program Management area or in the Output area to select the media. 

 In the Media Properties area within the Output area, click Opacity to set the nontransparent degree of the 

layer. 

Figure 5-28 Set layer opacity 

 

 Drag the slider to adjust the layer opacity degree, or enter a value in the text box below Reset to precisely 

adjust the layer opacity degree. 

The value range is 0 to 100. 0 stands for totally transparent and 100 stands for nontransparent. 

5.4.6   Set Layer Color 

You can adjust the layer color parameters to adjust the output image effect. The related parameters are shown 
below. 
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Figure 5-29 Layer image quality 

 

Basic Color Settings 

 Color parameters 

Parameter Description 

Brightness 
Adjust the brightness or darkness of the image. 

The value ranges from 0 to 100 and defaults to 50. 

Contrast 
Adjust the difference in brightness between light and dark areas of the image.  

The value ranges from 0 to 100 and defaults to 50. 

Saturation 

Adjust the strength or purity of the colors of an input source image. The larger the 
saturation, the more vivid the input source image; the smaller the saturation, the larger 
the image grayscale.  

The value ranges from 0 to 100 and defaults to 50. 

Hue 
Adjust the distinction between colors. 

The value ranges from –180 to +180 and defaults to 0. 

Apply to All Apply all the parameter settings to all the layers. 

Advanced Color Settings 

 Click Advanced to open the Advanced Color Settings window. 

Figure 5-30 Advanced color settings 

 

 Select Temperature/Tone to adjust the color temperature, color tone and gain compensation of the output 

image. 
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 Color Temperature: Adjust the cold or warm tendency of the image. The value range is [-3000, 10000] and 
the default value is 0. Move the slide block leftward, the color will be colder; move the slide block 
rightward, the color will be warmer.  

 Color Tone: Adjust the color effect of the image. The value range is [-40, 30] and the default value is 0. 

 Gain Compensation: Adjust the image output effect together with the color temperature and color tone. The 
value range is [-100, 100] and the default value is 0. 

 Select Curve to adjust the image channel or overall effect using the curve. 

The curve can help to adjust the brightness value of full grayscale images such as low gray, mid-tone, and 
high brightness. When the image is a low grayscale one and darker, you can raise the left half of the curve to 
improve the brightness of the low grayscale part of the image. 

When you want to adjust the overall image effect, select RGB; when you want to adjust a single channel, 
select R, G and B and adjust the single channel, respectively. 

When adjusting the curve, click on the curve to create an adjustment anchor point, and then simply drag the 
anchor point for adjustment. 

Notes: 

• At most 17 anchor points can be added for each channel. 

• Limitations: The moving range of multiple anchor points on the Y axis is 0-256, and the moving range of 
multiple anchor points on the X axis is limited by the X values of other points. Between two points, a 
draggable anchor point X value is added. Its adjustable range is between the X values of the previous 
two points. If you drag it beyond this range, the anchor point will disappear. 

Apply Color Settings 

Apply to All: Apply the basic and advanced color settings to all the layers. 

Reset: Reset all the color parameters to defaults. 

5.4.7   Crop Layers 

Crop a certain part of the layer image and make it display in the output area. 

 Click the playing media in the Program Management area or in the Output area to select the media. 

 In the Media Properties area within the Output area, click Crop to set the cropping parameters. 

Figure 5-31 Crop layers 

 

 Set the position and size of the cropped area. 

 Position: 

− X: Set the distance between the left edge of the cropped area and the left edge of the layer. 

− Y: Set the distance between the top edge of the cropped area and the top edge of the layer. 

 Size:  

− Width: Set the width of the cropped area. 

− Height: Set the height of the cropped area. 
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The cropping takes effect in real time and the cropping result is shown as follows. 

Figure 5-32 Cropping 

 

5.4.8   Set Layer Effects 

Layer effect settings include blurring, keying, mask and inverting colors. 

 Click the playing media in the Program Management area or in the Output area to select the media. 

 In the Media Properties area within the Output area, click Effect to set the related parameters. 

Figure 5-33 Layer effect settings 

 

Blur 

You can set whether to blur the layer image. 

 Select Blur to turn on the function. 

 Drag the slider to adjust the blurring degree. 

The value range is 0 to 100, and it defaults to 0. 

 0: Do not blur the layer image. 

 100: Blur the layer image to the greatest extent. 
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Color Keying 

Color keying is used to key out a solid-color background and replace it with transparency. 

 Click  and select the color area to be removed. 

 Pick the desired color. 

After the color is selected, the picked color, the color Hex and RGB values are displayed next to , or you 
can also set the Hex and RGB values to specify the color. 

 Select Color Keying to turn on the function and remove the selected color in the layer image. 

Mask 

The mask function is used to remove the undesired part of the layer image. 

 Select Mask to turn on the function. 

 Select the layer mask template. The default option is None. 

 None: Do not mask the layer image. 

 Rectangle: Mask the layer image, and the cropped part is left as a rectangle. 

 Set the height of the mask area (top and bottom) and the width of the mask area (left and right). 

 Top: Set the height of the top mask area. 

 Bottom: Set the height of the bottom mask area. 

 Left: Set the width of the left mask area. 

 Right: Set the width of the right mask area. 

Note: 

After the mask settings are completed, only the central area is kept. If Invert Selection is selected, the central 

area will be masked and the originally masked area will be displayed. 

5.4.9   Set Webpage Tabs 

When you configure a webpage media for the layer of a program, this function is available. 

When there are multiple tab pages, you can configure different tabs for the programs or layers. 

 Select the desired webpage media in the stage or program area. 

 Click Webpage Tab to show the tab setting options. 

 Select the current webpage tab name next to Main Tab. 

5.4.10   Set Sound Channel Mapping 

You can configure the sound card for the layer media to output the media audio from different sound cards. 

 Select the desired media from the program management area or the output editing area. 

 Select Sound Channel Mapping in the Media Properties area on the right side. 

Only the media with audio information supports this function. 
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Figure 5-34 Sound channel mapping 

 

 Select the desired sound card from the drop-down list. 

The default option is the sound card used by Kompass FX3. Please refer to 7.5 Audio Settings for specific 
sound channel mapping settings. 

 Click the desired sound channel and sound track to configure the output channel for each track. 

 At most 8 sound channels are supported. The specific sound track number depends on the actual media. 

 If the media file does not contain any sound track information, the sound channel settings are not 
supported. 

5.4.11   Set Scheduled Programs 

After the program editing, you can realize automatic playback of the programs according to the scheduled time 
and times. 

 Click  at the bottom of the main user interface to open the Scheduled Playback window. 

Figure 5-35 Scheduled programs 

 

 Click New Task at the top right of the window to create a new playback task. 
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Figure 5-36 Playback tasks 

 

 Set the start date and end date of the task in the Effective area. 

 Click  next to the effective time to add a new playback task. 

Figure 5-37 Set scheduled programs 

 

10. Select the desired programs in the Program List area on the left. 

11. Click  to add the selected programs to Plan List. 

The programs will be played according to the sequence (from the top to the bottom) in the Plan List area. 

If you want to adjust the playback sequence, please select the programs based on your desired priority 
and then add them to the plan list. If you select and add multiple programs, the programs will be added to 
the plan list based on their original sequence in the program list.  

12. Click OK to complete the settings. 

 Click OK to show the tasks and plans. 
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Figure 5-38 Set playback tasks 

 

 Select the program playback mode next to Mode. The options include Time and Times. 

 Time: The programs will be played by their own durations circularly. 

 Times: The programs will be played according to the set playback times. 

 Set the start and end time within the schedule range. 

13. Set the automatic start time of the program in the From area. 

14. Set the automatic end time of the program in the to area. 

When the playback mode is set to Times, the end time of the program is 23:59:59 by default and cannot 

be changed. 

 Set the program playback times. 

Click the number next to Times to activate the times setting function. Enter the desired times and then the 
program will be played automatically according to the set times. When the playback mode is set to Time, the 
playback times of the program is 1 by default and cannot be changed. 

 Set the program playback date. The options include Every day, Monday, Tuesday, Wednesday, Thursday, 

Friday, Saturday and Sunday. 

 Every day: The plan will be played every day automatically according to the schedule within the effective 
time range. 

 Monday: The plan will be played every Monday automatically according to the schedule within the effective 
time range. 

 Tuesday: The plan will be played every Tuesday automatically according to the schedule within the 
effective time range. 

 Wednesday: The plan will be played every Wednesday automatically according to the schedule within the 
effective time range. 

 Thursday: The plan will be played every Thursday automatically according to the schedule within the 
effective time range. 

 Friday: The plan will be played every Friday automatically according to the schedule within the effective 
time range. 

 Saturday: The plan will be played every Saturday automatically according to the schedule within the 
effective time range. 

 Sunday: The plan will be played every Sunday automatically according to the schedule within the effective 
time range. 

 Set the action after the program stops. The options include FTB and Current Frame. 

 FTB: After the program playback ends or the playback time reaches the end time, the output image fades 
to black. 
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 Current Frame: FTB: After the program playback ends or the playback time reaches the end time, the 
output image displays the frame when the program stops. 

 Repeat Step 4 to Step 10 to add more plans under the current task. 

 Repeat Step 2 to Step 10 to add more tasks and plans. 

Notes: 

• Different plans cannot have the overlapping time slots. 

• Different tasks cannot have the overlapping time slots. 

Other Operations 

 Delete plans 

In the Scheduled Playback window, click  next to the desired plan to delete the plan. 

 Delete tasks 

In the Scheduled Playback window, click  next to the desired task to delete the task. 

 Edit plans  

Click  at the desktop taskbar to open the Scheduled Playback window and then add, edit or delete 

the desired plans or tasks. 

Save Projects 

You can save the project when you are satisfied with the project settings for easy use in future. 

Go to Project > Save or Save As to save the current project file (*.fxsp) to your local storage. 

The project file includes the following information: 

 Media files 

 Output editing settings 

 Programs and all layers in the programs 

Package Projects 

You can save the edited project and the imported media files as an independent project file for easy and 
convenient use on any computers in the future. 

 Go to Project > Package Project. 

 Enter the project file name, and select the save location and desired files in the displayed window. 

Figure 5-39 Package projects 
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 Used: The media files that have been imported to the media library and added into the programs 

 All: All the media files that have been imported to the media library 

 Click Package. 

6   Link 

Link Settings 

Application Scenarios 

 Kompass FX3 supports the primary and backup outputs. If the primary device fails or the cable connection 
of the primary device breaks, the backup device will take the responsibilities of the primary device 
seamlessly to ensure the output will not go black. 

 Kompasss FX3 supports the master and slave outputs. If the master device cannot load the screen 
independently, one or multiple slave devices can help load the screen. You can configure the master and 
slave outputs on the master device to manage the playback images on the screen. 

Figure 6-1 Applications 

 

Prerequisites 

 The primary and backup devices or the master and slave devices must be on the same network segment. 

 The sync card must be installed into the master and slave devices. 

Operating Procedure 

 In the Kompass FX3 of the primary device, go to Link > Link Settings to open the link settings window. 

The system will automatically search for the IP addresses of the devices where Kompass FX3 is enabled on 
the current network segment, and then show the IP addresses in the Device List area. 
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Figure 6-2 Link settings 

 

 Add a backup device. 

15. In the Device List area, select the IP address of the device that you want to add as a backup device. 

16. Click and drag the selected IP address to the device on the right side as shown in the following figure. 

 Add a slave device. 

17. In the Device List area, select the IP address of the device that you want to add as a slave device. 

18. Click and drag the selected IP address to the blank area on the right side as shown in the following figure. 

You can also add a backup device to the slave device. At this time, this slave device serves as the primary 
in its own primary and backup relation. 

Figure 6-3 Add backup or slave devices 

 

 Manage the backup or slave device. 

19. In the topology, select the backup or slave device. 

20. Right click the device to open the context menu. 

− Connect: If the primary and backup connection or the master and slave connection fails, select this 
option to manually connect the devices. 

− Delete: Break the primary and backup connection or the master and slave connection. 
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− Power On: Power on the backup or slave device remotely. 

− Power Off: Power off the backup or slave device remotely. 

− Restart: Restart the Kompass FX3 software on the backup or slave device. 

 Click OK to complete the backup or slave device settings. 

Update to Backup 

In the Kompass FX3 of the primary device, go to Link > Update to Backup to manually update all the data on 

the primary device to the backup device. 

On the main user interface, click Update on the top right to view the updating progress, i.e., the media 

transmission progress, as shown below. 

Figure 6-4 Update progress 

 

Update to Slave 

Manually update all the data on the master device to the slave device. 

 In the Kompass FX3 of the master device, go to Link > Update to Slave. 

 Select the desired slave device from the window that appears. 

Figure 6-5 Update to slave 

 

 Click OK. 

On the main user interface, click Update on the top right to view the updating progress, i.e., the media 
transmission progress. If the slave device has a backup device, the Update to Slave action will also update 

the backup device data simultaneously. 
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Disconnect 

In the Kompass FX3 of the backup or slave device, go to Link > Disconnect to break the connection between 

the primary and backup devices or the connection between the master and slave devices. 

 In the Kompass FX3 of the primary or master device, this option is greyed out. 

 In the Kompass FX3 of the primary or master device, go to Link > Link Settings to break the binding 

relation between the primary and backup devices or between the master and slave devices in the topology.  

7   Settings 

System Settings 

Set the startup-related settings. Go to Settings > System Settings to open the System Settings window. 

Figure 7-1 System settings 

 

 Auto start after power on:  

− Selected: Kompass FX3 will be started automatically when OS starts. 

− Deselected: Kompass FX3 will not be started when OS starts. 

 Open recent project after startup: 

− Selected: The recently-opened project will be opened when Kompass FX3 starts. 

− Deselected: A new project will be created when Kompass FX3 starts. 

 Play project after opened: 

− Selected: The recently played project will be played automatically when Kompass FX3 starts. 

− Deselected: No project will be played when Kompass FX3 starts. 

 Adapter: Select the adapter for the video rendering of the software. After the selection, you must restart the 
server where Kompass FX3 is installed. 

 Log Storage: Set the save duration for the playback logs. The supported options include 1 Month, 3 
Months, 6 Months, 12 Months and Forever. 

 Storage Path: Select the save location for the playback logs. 

− Click Browse to select the desired folder. 

− Click Open to open the folder where logs are saved. 

− Click Clear to clear the cache of the logs. 
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 Cache Path: Select the save location for the media files downloaded from the primary device. 

− Click Browse to select the desired folder. 

− Click Open to open the folder where the files are saved. 

− Click Clear to clear the cache of the files. 

Output Settings 

Set the program transition effect, transition duration, as well as the FTB status and duration. 

Go to Settings > Output Settings to open the Output Settings window. 

Figure 7-2 Output settings 

 

 Mute FTB: Set whether to turn off the audio during the FTB process. 

− Selected: The audio will be turned off. 

− Deselected: The audio will be output as normal. 

 FTB Duration: Set the time length the FTB process lasts. The value range is 0s to 2.00s and it defaults to 
0.5s. 

 Program Transition: Set the program transition effect. The options include Fade and Cut. 

 Transition Duration: Set the time length the fade effect lasts. When Program Transition is set to Fade, 

this option is available. The value range is 0s to 2.00s and it defaults to 0.5s. 

 MFPS/EFPS: The real-time frame rate 

− MFPS: After checked, the real-time frame rate will be displayed at the bottom left of the preview 
window. 

− EFPS: After checked, the real-time frame rate will be displayed at the bottom left of the output image. 

 Cache Program: Set whether to enable the program cache function. 

− Selected: The function is enabled. 

− Deselected: The function is disabled. 

 After Program Ends: Set the default playback action after the newly-added program stops playing. The 
setting here do not affect the existing programs. 

− Loop Playback: The newly-added program will be played circularly. 

− Jump to Next: When the newly-added program stops playing, the first program on its right will be 
played. 

− Stop Playing: When the playback of the newly-added program ends, the playing will be stopped. 

 Office Type: Select the application program that will be used to open the PowerPoint files. 
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− Default: The PowerPoint files will be opened in the default tool of your media server. 

− Microsoft Office: The PowerPoint files will be opened in Microsoft Office. 

− WPS Office: The PowerPoint files will be opened in WPS Office. 

 PowerPoint Playback: Set the switching mode for the PowerPoint slides. 

− Animation: The animation effects will be shown during the slide switching. 

− Picture: The slides are shown in pictures, without any transition effects. 

 PowerPoint Resolution: Select the desired output resolution of the PowerPoint file. 

Multiple Displays 

When two or mode displays are connected, you can set to duplicate the desktop or set to show different 
content on each display, that is, extend mode. Go to Settings > Multiple Displays to select the desired mode. 

 Duplicate: All the connected displays output the same content. 

 Extend: The connected displays output the different contents. The extend mode is the default option. 

External Control 

Kompass FX3 supports remote control and control via a control device, allowing users to manage Kompass 
FX3 conveniently. For details on the commands and command writing rules of remote controlling and 
controlling via a control device, please see Control Protocol of NovaStar Playback and Control Software. 

Go to Settings > External Control to open the External Control window. 

Figure 7-3 External control 

 

7.4.1   Control via Network 

For control via a network, Kompass FX3 supports remote control via UDP and TCP/IP protocols. 

Go to Settings > External Control to open the External Control window shown in Figure 7-3. 

Control via UDP Protocol 

 Select UDP to enable UDP control. 

 In the text box next to Port, enter the UDP port number of Kompass FX3. 

The UDP port number ranges from 1024 to 65535 and defaults to 18959. 

 Click Listen. Kompass FX3 will automatically check whether the port number you entered in Step 2 is 

occupied. 
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 Occupied: Re-enter a port number and click Listen again to check. 

 Not occupied: The UDP control settings are completed. 

Control via TCP/IP Protocol 

 Select TCP/IP to enable TCP/IP control. 

 In the text box next to Port, enter the TCP/IP port number of Kompass FX3. 

The TCP/IP port number ranges from 1024 to 65535 and defaults to 19958. 

 Click Listen. Kompass FX3 will automatically check whether the port number you entered in Step 2 is 

occupied. 

 Occupied: Re-enter a port number and click Listen again to check. 

 Not occupied: The TCP/IP control settings are completed. 

7.4.2   Control via Serial Port 

To control Kompass FX3 via serial port, use a serial cable to connect the control device to the computer where 
Kompass FX3 is installed. 

 Go to Settings > External Control > Serial Port to open the window shown in Figure 7-4. 

Figure 7-4 Serial port control 

 

 Click Scan. The system will automatically scan the serial ports of the computer. 

 Click the drop-down box next to Serial Port and select the serial port currently connected to the control 

device. 

 Set Baud Rate, Data Bits, Parity, and Stop Bits. 

Note: 

The parameter values of baud rate, data bits, parity and stop bits of the serial port on the control device must 

be the same as the values of those parameters you set in Kompass FX3. 

 Click Open Port to finish serial port settings. 

 Click Close to close the External Control window. 

7.4.3   Control via App 

Kompass FX3 built in a media server can be controlled via an App named VICP Visual Intelligent Control 
Platform. The connections for App control are as follows. 
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Figure 7-5 Connections for App control  

 

Connection Requirements 

The media server, H series device and Pad device with VICP installed must be on the same network segment. 

Media Server Configuration 

 Obtain the IP address of the media server. 

a. On the media server, press Win and R keys simultaneously to open the Run command dialog window. 

Figure 7-6 Run command window 

 

b. Type “cmd” in the search box and then press Enter to open the command prompt. 

c. Type “ipconfig” and then press Enter to show the device IP address. 

Figure 7-7 Obtain the IP address of the media server 
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IPv4 address indicates the IP address of the media server. 

 Configure the listening port of the media server. 

1. Run Kompass FX3 and then go to Settings > External Control to open the external control settings 

window. 

2. Select the Network tab. 

3. Check the box in front of TCP/IP to enable the TCP/IP control. 

4. Enter the port number in the text box next to Port. 

5. Click Listen to enable the listening for the external control. 

If the port is occupied, a prompt saying “Listening failed: The port is being used.” is shown. You 
must re-enter a port number and click Listen again. 

If a prompt saying “Listening succeeded.” is shown, the listening succeeds and the Listen button is 
highlighted. Click OK to complete the settings. 

6. Click Close to complete the port settings. 

Figure 7-8 Port settings 

 

Audio Settings 

You can configure the correspondent relations between the sound cards and sound channel mappings. One 
sound card corresponds to one mapping only. 

For example, if you select Map 01 for the layer media A, B and C at the same time, the audio information in 
these three media will be output via the sound card that Map 01 corresponds to. If you want to change the 
sound card for these three media, you only need to change the sound card that Map 01 corresponds to rather 
than set the sound card for each media respectively. Xi'an NovaStar T
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Figure 7-9 Audio settings 

 

 Three mappings are displayed by default. You can click New at the top right to add a new mapping. 

 The drop-down list shows all the sound card devices of the device. 

Kompass FX3 supports the hot swapping of the sound card device and you do not need to restart the 
software after a new sound card is installed. 

 Configure the sound channel count for the mapping. The supported options include Default, 2, 4, 6 and 8. 

Default indicates the sound channel count of the corresponding sound card. 

 

8   Help 

Transcoding Assistant 

Kompass FX3 supports the conversion of the video coding format, code rate, resolution and frame rate, to 
satisfy the requirements of different playback scenarios. 

 Go to Help > Transcoding Assistant to open the transcoding settings window. 
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Figure 8-1 Transcoding assistant 

 

 Click Add at the bottom to open the local folder where you can select the desired file. 

You can also add multiple files by pressing the Ctrl key and selecting the files simultaneously. 

 Click Select File to add them into the assistant. 

 Select the target file for transcoding. 

On the right side, set the parameters of Coding, Quality, Code Rate, Frame Rate, Resolution and Audio. 

 Coding: Set the coding format of the transcoded video. The supported options include Adaptive, h264, 
h265, VP9 and hap.  

When Self-Adaptive is selected, the video will be transcoded according to the original video coding. 

 Quality: Set the quality of the transcoded video. The supported options include Low, Medium and High. 

− High: Keep the quality of the transcoded video the same as the original video quality. 

− Low: The quality of the transcoded video is relatively blurred compared to the original video quality. 

− Medium: The quality of the transcoded video is between the high and low qualities. 

 Code Rate: Set the code rate of the transcoded video. The supported options include Self-Adaptive and 
Custom. 

− Adaptive: The code rates before and after the transcoding are the same. 

− Custom: Set the desired code rate and the video will be transcoded according to the set value. 

 Frame Rate: Set the frame rate of the transcoded video. The supported options include Self-Adaptive, 24, 
30, 60 and Custom. 

− Adaptive: The frame rates before and after the transcoding are the same. 

− 24/30/60: The frame rate after the transcoding will be 24 Hz, 30 Hz, and 60 Hz, respectively. 

− Custom: Set the desired frame rate and the video will be transcoded according to the set value. 

 Resolution: Set the resolution of the transcoded video. 

− W: Set the horizontal size of the transcoded video. The value defaults to 1920 and can reach a 
maximum value of 16384. 

− H: Set the vertical size of the transcoded video. The value defaults to 1080 and can reach a maximum 
value of 16384. 

 Audio: Set how to deal with the audio that comes with the video. The supported options include Keep and 
Remove.  

− Keep: The transcoded video retains the audio in the video before transcoding. 
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− Remove: The transcoded video display pure images without any audio. 

 Repeat Step 4 and Step 5 to set the transcoding parameters for other video files. 

 Click Transcode and the system will automatically start the transcoding process. 

When the progress reaches 100% in the Progress column, the transcoding completes. After the transcoding, 
the video will be saved in the path specified in Save Path. 

 Click Open to open the local folder where you can view the transcoded files. 

 Click Change to change the save path. 

 Click Delete at the bottom to delete the selected video files. 

Play Log 

Kompass FX3 supports the automatic statistics of the playback logs. When you select a certain date, time 
period or media name, you can search for the desired logs. The log information includes the number, media 
name, start time, end time, total duration and playback times. 

 Go to Help > Play Log to open the playback log window. 

Figure 8-2 Play log 

 

 Click Date and select the desired time period. The supported options include Today, Recent 7 Days, Recent 

1 Month and Recent 3 Months. 

Note: 

Before you use this function, please set the value range of Log Storage greater than the time period range 

you set here. 

 Set the start and end time. 

 Enter the media file name in the text box next to Media Name to search for the payback logs of this single 

media, otherwise the playback logs of all media files will be searched and displayed. 

 Click Search to start the search and statistics. 

Click Export to export the playback logs to your local computer. 
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User Manual 

On the menu bar, go to Help > User Manual, or press the F1 key on the keyboard to open the user manual. 

About 

On the menu bar, go to Help > About to view the software information. 

9   Language 

Kompass FX3 supports two interface languages: English and Chinese. You do not need to restart the software 
after the UI language is changed. 

 Go to 语言/Language > English to set the UI language to English. 

 Go to 语言/Language > 中文 to set the UI language to Simplified Chinese. 
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10   Specifications 

Electrical 
Specifications 

Power 
connector 

100–240V~  10–5A  47–63Hz 

Power 
consumption 

500 W 

Operating 
Environment 

Temperature 0°C to 40°C 

Humidity 0% RH to 80% RH, non-condensing 

Storage 
Environment 

Temperature –10°C to +60°C 

Humidity 0% RH to 95% RH, non-condensing 

Physical 
Specifications 

Dimensions 483 mm × 177 mm × 520 mm 

Net weight 25.9 kg 

Packing 
Information 

Packing box 690 mm × 570 mm × 300 mm 

Accessories 1x Power cable 

4x DP cables 

1x DP to HDMI adapter 

1x Type-C to HDMI converter cable* 

1x Keyboard and mouse suit 

1x DVD (OS included) 

1x Quick Start Guide 

1x Safety Manual 

1x Certificate of Approval 

 Note 

*When the HPG4000 graphics card is selected, the 
accessories include a Type-C to HDMI converter cable. 
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